Pada sub bab terakhir ini merupakan lab dari semua sub bab sebelumnya (vlan access, vlan trunk, vtp, router on stick) . Berikut topologi nya :
Tabel alamat IP :
Pertama, masuk ke Router Utama kemudian hidupkan interface yang mengarah ke SW1 .
SW1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SW1(config)#vlan 10
SW1(config-vlan)#name ruang-guru
SW1(config-vlan)#exit
SW1(config)#vlan 20
SW1(config-vlan)#name ruang-meeting
SW1(config-vlan)#exit
SW1(config)#vtp mode server
Device mode already VTP SERVER.
SW1(config)#vtp domain sayabisa.com
Changing VTP domain name from NULL to sayabisa.com
SW1(config)#vtp password sayajoss
Setting device VLAN database password to sayajoss
SW1(config)#vtp version 2
SW1(config)#int fa0/1
SW1(config-if)#switchport mode trunk
SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
SW1(config-if)#switchport trunk allowed vlan 10,20
SW1(config-if)#exit
SW1(config)#int fa1/1
SW1(config-if)#switchport mode trunk
SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to up
SW1(config-if)#switchport trunk allowed vlan 10,20
SW1(config-if)#exit
SW1(config)#int fa3/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20
SW1(config-if)#exit
SW1(config)#int fa2/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20
SW1(config-if)#exit
SW1(config)#
------------------------------------------------------------------------------------
Setelah konfigurasi vlan access,trunk dan vtp server sudah selesai, masuk ke SW2 untuk konfigurasi vtp client, trunk, serta access .
------------------------------------------------------------------------------------
------------------------------------------------------------------------------------
SW2>en
SW2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SW2(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW2(config)#vtp domain sayabisa.com
Domain name already set to sayabisa.com.
SW2(config)#vtp password sayajoss
Setting device VLAN database password to sayajoss
SW2(config)#int fa0/1
SW2(config-if)#switchport mode trunk
SW2(config-if)#exit
SW2(config)#int fa2/1
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10
SW2(config-if)#exit
SW2(config)#int fa1/1
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10
SW2(config-if)#exit
SW2(config)#
------------------------------------------------------------------------------------
Cek konfigurasi vtp pada SW2, apakah vlan yang ada pada SW1 sudah sinkron dengan vlan database SW2 .
------------------------------------------------------------------------------------
SW2(config)#do sh vlan bri
VLAN Name Status Ports
1 default active Fa3/1, Fa4/1, Fa5/1
10 ruang-guru active Fa1/1, Fa2/1
20 ruang-meeting active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
SW2(config)#
------------------------------------------------------------------------------------
Baik, selanjutnya konfigurasi alamat ip pada masing masing perangkat end devices (komputer) .
PC0 :
PC2 :
PC3 :
Langkah terakhir yaitu pengujian apakah semua perangkat sudah terhubung satu sama lain.
PC0 PC2
------------------------------------------------------------------------------------
C:\>ping 192.168.20.2
Pinging 192.168.20.2 with 32 bytes of data:
Reply from 192.168.20.2: bytes=32 time<1ms TTL=127
Reply from 192.168.20.2: bytes=32 time<1ms TTL=127
Reply from 192.168.20.2: bytes=32 time=1ms TTL=127
Reply from 192.168.20.2: bytes=32 time=1ms TTL=127
Ping statistics for 192.168.20.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
------------------------------------------------------------------------------------
C:\>
PC1 PC3
C:\>ping 192.168.20.3
Pinging 192.168.20.3 with 32 bytes of data:
Reply from 192.168.20.3: bytes=32 time<1ms TTL=127
Reply from 192.168.20.3: bytes=32 time=10ms TTL=127
Reply from 192.168.20.3: bytes=32 time=11ms TTL=127
Reply from 192.168.20.3: bytes=32 time=10ms TTL=127
Ping statistics for 192.168.20.3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 11ms, Average = 7ms
------------------------------------------------------------------------------------
C:\>
Pastikan semua hasil ping menunjukan Reply .
Tabel alamat IP :
Pertama, masuk ke Router Utama kemudian hidupkan interface yang mengarah ke SW1 .
------------------------------------------------------------------------------------
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#
------------------------------------------------------------------------------------
Setelah itu, buat sub interface sesuai vlan yang dibutuhkan :
Router(config)#int fa0/0.10
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#exit
Router(config)#int fa0/0.20
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config-subif)#exit
Router(config)#
------------------------------------------------------------------------------------
Cek konfigurasi ip address kita :
------------------------------------------------------------------------------------
Router(config)#do show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset up up
FastEthernet0/0.10 192.168.10.1 YES manual up up
FastEthernet0/0.20 192.168.20.1 YES manual up up
FastEthernet1/0 unassigned YES unset administratively down down
Serial2/0 unassigned YES unset administratively down down
Serial3/0 unassigned YES unset administratively down down
FastEthernet4/0 unassigned YES unset administratively down down
FastEthernet5/0 unassigned YES unset administratively down down
Router(config)#
------------------------------------------------------------------------------------
Setelah itu masuk ke SW1, kemudian buat vlan sesuai vlan yang dibutuhkan dan konfigurasi vlan trunk , access dan vtp server .
------------------------------------------------------------------------------------
------------------------------------------------------------------------------------
SW1>enSW1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SW1(config)#vlan 10
SW1(config-vlan)#name ruang-guru
SW1(config-vlan)#exit
SW1(config)#vlan 20
SW1(config-vlan)#name ruang-meeting
SW1(config-vlan)#exit
SW1(config)#vtp mode server
Device mode already VTP SERVER.
SW1(config)#vtp domain sayabisa.com
Changing VTP domain name from NULL to sayabisa.com
SW1(config)#vtp password sayajoss
Setting device VLAN database password to sayajoss
SW1(config)#vtp version 2
SW1(config)#int fa0/1
SW1(config-if)#switchport mode trunk
SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
SW1(config-if)#switchport trunk allowed vlan 10,20
SW1(config-if)#exit
SW1(config)#int fa1/1
SW1(config-if)#switchport mode trunk
SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to up
SW1(config-if)#switchport trunk allowed vlan 10,20
SW1(config-if)#exit
SW1(config)#int fa3/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20
SW1(config-if)#exit
SW1(config)#int fa2/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20
SW1(config-if)#exit
SW1(config)#
------------------------------------------------------------------------------------
Setelah konfigurasi vlan access,trunk dan vtp server sudah selesai, masuk ke SW2 untuk konfigurasi vtp client, trunk, serta access .
------------------------------------------------------------------------------------
SW2>en
SW2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SW2(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW2(config)#vtp domain sayabisa.com
Domain name already set to sayabisa.com.
SW2(config)#vtp password sayajoss
Setting device VLAN database password to sayajoss
SW2(config)#int fa0/1
SW2(config-if)#switchport mode trunk
SW2(config-if)#exit
SW2(config)#int fa2/1
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10
SW2(config-if)#exit
SW2(config)#int fa1/1
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10
SW2(config-if)#exit
SW2(config)#
------------------------------------------------------------------------------------
Cek konfigurasi vtp pada SW2, apakah vlan yang ada pada SW1 sudah sinkron dengan vlan database SW2 .
------------------------------------------------------------------------------------
SW2(config)#do sh vlan bri
VLAN Name Status Ports
1 default active Fa3/1, Fa4/1, Fa5/1
10 ruang-guru active Fa1/1, Fa2/1
20 ruang-meeting active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
SW2(config)#
------------------------------------------------------------------------------------
Baik, selanjutnya konfigurasi alamat ip pada masing masing perangkat end devices (komputer) .
PC0 :
PC1 :
PC3 :
PC0 PC2
------------------------------------------------------------------------------------
C:\>ping 192.168.20.2
Pinging 192.168.20.2 with 32 bytes of data:
Reply from 192.168.20.2: bytes=32 time<1ms TTL=127
Reply from 192.168.20.2: bytes=32 time<1ms TTL=127
Reply from 192.168.20.2: bytes=32 time=1ms TTL=127
Reply from 192.168.20.2: bytes=32 time=1ms TTL=127
Ping statistics for 192.168.20.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
------------------------------------------------------------------------------------
C:\>
PC1 PC3
C:\>ping 192.168.20.3
Pinging 192.168.20.3 with 32 bytes of data:
Reply from 192.168.20.3: bytes=32 time<1ms TTL=127
Reply from 192.168.20.3: bytes=32 time=10ms TTL=127
Reply from 192.168.20.3: bytes=32 time=11ms TTL=127
Reply from 192.168.20.3: bytes=32 time=10ms TTL=127
Ping statistics for 192.168.20.3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 11ms, Average = 7ms
------------------------------------------------------------------------------------
C:\>
Pastikan semua hasil ping menunjukan Reply .